そういえば、「FLR Patchというのがある」というのを忘れていました。このパッチを当てると解決するようです。
http://old.nabble.com/Problems-with-pci-passthrough-with-Xen-3.4.2-td26713926.html
ただ、ワシにはむりでござるっ……(スキル的な意味で)
で、Xenのバージョン4ではパッチが取り込まれていて、Xenのオプションとして指定できるようになるみたいです。
http://lists.xensource.com/archives/html/xen-devel/2009-12/msg00681.html

(pci-passthrough-strict-check yes)

ただし、バックポートの可能性が低そうなメールもレスに含まれていて、どうなるのか?といった感じです(英語はなんとなくしか読めないので)。

このエントリ

きのうポストしたつもりが失敗していたらしく、バックアップされた内容が出てきてびっくりした。